본문 바로가기
Game Programming

Facebook sdk , com.google.android.material.material-1.7.0 alpha issue.

by 게임혼 2022. 6. 21.

몇몇 facebook sdk에는 일부 버전처리가 잘 안되어 있습니다.

 

그래서 해당 sdk를 사용하는 다른 sdk의 경우 EDM4U에서 라이브러리 충돌이 일어납니다.

 

컴투스라던지 토스트라던지 말이죠.

 

이런 일이 생기면!

 

일단 해당 라이브러리 버전을 봅니다.

 

androidx.appcompat:appcompat:1.4.0-alpha01 의 경우 android sdk 31입니다.

 

유니티 버전에 따라 다르지만 아무래도 손이 가죠.

 

gradle도 6.1.1로 변경해야 합니다.

 

뭐 이정도는 다들 문제 없을겁니다.

 

그리고 빌드하면 끝.

물론 상황에 따라 gradle 템플릿도 추가하고 jet 중복방지 처리도 해야 합니다.

 

그래도 큰 문제는 더이상 없을 겁니다.

'Game Programming' 카테고리의 다른 글

GamePot 20220217 iOS 주의점  (0) 2022.10.01
OPENCV 내부 채우기  (0) 2022.09.02
SSL 테스트  (0) 2022.06.17
골프 타격 핫스팟 만들기  (0) 2022.06.10
No 'Access-Control-Allow-Origin' header Issue  (0) 2022.03.12

댓글0